Patchwork [4,of,4,for-reference] obsolete: use format version 1 as the default for obsstore

login
register
mail settings
Submitter Pierre-Yves David
Date Oct. 10, 2014, 11:25 p.m.
Message ID <f8a4ce6fb27a8b32baeb.1412983508@marginatus.alto.octopoid.net>
Download mbox | patch
Permalink /patch/6215/
State Accepted
Headers show

Comments

Pierre-Yves David - Oct. 10, 2014, 11:25 p.m.
# HG changeset patch
# User Pierre-Yves David <pierre-yves.david@fb.com>
# Date 1410915464 25200
#      Tue Sep 16 17:57:44 2014 -0700
# Node ID f8a4ce6fb27a8b32baeb3bd27e3e1510f87105b0
# Parent  9a7d0f7e05619c4da2b6172d42c1c9fe7515f699
obsolete: use format version 1 as the default for obsstore

Patch

diff --git a/mercurial/obsolete.py b/mercurial/obsolete.py
--- a/mercurial/obsolete.py
+++ b/mercurial/obsolete.py
@@ -448,11 +448,11 @@  class obsstore(object):
     # meta:    binary blob, encoded metadata dictionary
     # date:    (float, int) tuple, date of marker creation
     # parents: (tuple of nodeid) or None, parents of precursors
     #          None is used when no data has been recorded
 
-    def __init__(self, sopener, defaultformat=_fm0version):
+    def __init__(self, sopener, defaultformat=_fm1version):
         # caches for various obsolescence related cache
         self.caches = {}
         self._all = []
         self.precursors = {}
         self.successors = {}