Patchwork D12349: tests: remove Python < 3 check

login
register
mail settings
Submitter phabricator
Date March 4, 2022, 3:33 a.m.
Message ID <differential-rev-PHID-DREV-mlmv3h4nbdneu5dazokz-req@mercurial-scm.org>
Download mbox | patch
Permalink /patch/50688/
State New
Headers show

Comments

phabricator - March 4, 2022, 3:33 a.m.
indygreg created this revision.
Herald added a reviewer: hg-reviewers.
Herald added a subscriber: mercurial-patches.

REVISION SUMMARY
  We require Python 3 now.

REPOSITORY
  rHG Mercurial

BRANCH
  default

REVISION DETAIL
  https://phab.mercurial-scm.org/D12349

AFFECTED FILES
  tests/testlib/sigpipe-remote.py

CHANGE DETAILS




To: indygreg, #hg-reviewers
Cc: mercurial-patches, mercurial-devel

Patch

diff --git a/tests/testlib/sigpipe-remote.py b/tests/testlib/sigpipe-remote.py
--- a/tests/testlib/sigpipe-remote.py
+++ b/tests/testlib/sigpipe-remote.py
@@ -6,14 +6,6 @@ 
 import sys
 import time
 
-# we cannot use mercurial.testing as long as python2 is not dropped as the test
-# will only install the mercurial module for python2 in python2 run
-if sys.version_info[0] < 3:
-    ver = '.'.join(str(x) for x in sys.version_info)
-    exe = sys.executable
-    print('SIGPIPE-HELPER: script should run with Python 3', file=sys.stderr)
-    print('SIGPIPE-HELPER:   %s is running %s' % (exe, ver), file=sys.stderr)
-    sys.exit(255)
 
 if isinstance(sys.stdout.buffer, io.BufferedWriter):
     print('SIGPIPE-HELPER: script need unbuffered output', file=sys.stderr)