Patchwork D12315: setup: drop support for Python 3.5

login
register
mail settings
Submitter phabricator
Date March 3, 2022, 2:43 a.m.
Message ID <differential-rev-PHID-DREV-kflyw5dym6dw2zfeglwl-req@mercurial-scm.org>
Download mbox | patch
Permalink /patch/50656/
State New
Headers show

Comments

phabricator - March 3, 2022, 2:43 a.m.
indygreg created this revision.
Herald added a reviewer: hg-reviewers.
Herald added a subscriber: mercurial-patches.

REVISION SUMMARY
  We talked about this on the mailing list [1] and there seemed to be
  agreement that Python 3.5 is effectively dead and no longer worth
  supporting.
  
  So this commit changes our minimum version requirement to 3.6.2.
  
  [1] https://www.mercurial-scm.org/pipermail/mercurial-devel/2022-February/147885.html

REPOSITORY
  rHG Mercurial

BRANCH
  default

REVISION DETAIL
  https://phab.mercurial-scm.org/D12315

AFFECTED FILES
  setup.py

CHANGE DETAILS




To: indygreg, #hg-reviewers
Cc: mercurial-patches, mercurial-devel

Patch

diff --git a/setup.py b/setup.py
--- a/setup.py
+++ b/setup.py
@@ -5,17 +5,11 @@ 
 # 'python setup.py --help' for more options
 import os
 
-# Mercurial will never work on Python 3 before 3.5 due to a lack
-# of % formatting on bytestrings, and can't work on 3.6.0 or 3.6.1
-# due to a bug in % formatting in bytestrings.
-# We cannot support Python 3.5.0, 3.5.1, 3.5.2 because of bug in
-# codecs.escape_encode() where it raises SystemError on empty bytestring
-# bug link: https://bugs.python.org/issue25270
+# Mercurial can't work on 3.6.0 or 3.6.1 due to a bug in % formatting
+# in bytestrings.
 supportedpy = ','.join(
     [
-        '>=3.5.3',
-        '!=3.6.0',
-        '!=3.6.1',
+        '>=3.6.2',
     ]
 )