Patchwork [3,of,3,WEBSITE] Add mention of the last version to support Python 2

login
register
mail settings
Submitter Raphaël Gomès
Date Feb. 21, 2022, 5:37 p.m.
Message ID <a5d9e2ac253a5566579c.1645465049@alphare-carbon.lan>
Download mbox | patch
Permalink /patch/50551/
State New
Headers show

Comments

Raphaël Gomès - Feb. 21, 2022, 5:37 p.m.
# HG changeset patch
# User Raphaël Gomès <rgomes@octobus.net>
# Date 1645464575 -3600
#      Mon Feb 21 18:29:35 2022 +0100
# Node ID a5d9e2ac253a5566579cf5fd481a014ab414b979
# Parent  a2108539f22be784bf7d7a192228589e88f3a81e
# EXP-Topic python2-nuke
Add mention of the last version to support Python 2

This version will not exist until ~March 1st, so we may want to hold off
on getting this patch through.

Patch

diff -r a2108539f22b -r a5d9e2ac253a templates/downloads/index.html
--- a/templates/downloads/index.html	Mon Feb 21 18:28:23 2022 +0100
+++ b/templates/downloads/index.html	Mon Feb 21 18:29:35 2022 +0100
@@ -77,6 +77,11 @@ 
       <dd>For more information about version support, see
           <a href="https://www.mercurial-scm.org/wiki/SupportedPythonVersions">Supported
           Python Versions</a> on the wiki.</dd>
+      <dt>Python 2.7</dt>
+      <dd><a href="/release/mercurial-6.1.tar.gz">Mercurial 6.1</a>
+          is the last release to support Python 2. Use this if you need
+          to run Mercurial on old platforms and you cannot update your
+          Python installation.</dd>
       <dt>Python 2.6</dt>
       <dd><a href="/release/mercurial-4.2.3.tar.gz">Mercurial 4.2.3</a>
           is the last release to support Python 2.6. Use this if you need