Patchwork D11984: tests: use debugrequires in test-upgrade-repo.t

login
register
mail settings
Submitter phabricator
Date Jan. 12, 2022, 2:08 p.m.
Message ID <differential-rev-PHID-DREV-z2oyd4tzrsqrnwrhfi3x-req@mercurial-scm.org>
Download mbox | patch
Permalink /patch/50309/
State New
Headers show

Comments

phabricator - Jan. 12, 2022, 2:08 p.m.
marmoute created this revision.
Herald added a reviewer: hg-reviewers.
Herald added a subscriber: mercurial-patches.

REVISION SUMMARY
  Whenever possible, we use the `hg debugrequires` command instead of directly
  grepping the file.

REPOSITORY
  rHG Mercurial

BRANCH
  default

REVISION DETAIL
  https://phab.mercurial-scm.org/D11984

AFFECTED FILES
  tests/test-upgrade-repo.t

CHANGE DETAILS




To: marmoute, #hg-reviewers
Cc: mercurial-patches, mercurial-devel

Patch

diff --git a/tests/test-upgrade-repo.t b/tests/test-upgrade-repo.t
--- a/tests/test-upgrade-repo.t
+++ b/tests/test-upgrade-repo.t
@@ -1158,7 +1158,7 @@ 
   $ touch foo
   $ hg add --large foo
   $ hg -q commit -m initial
-  $ cat .hg/requires
+  $ hg debugrequires
   dotencode
   fncache
   generaldelta
@@ -1170,7 +1170,7 @@ 
 
   $ hg debugupgraderepo --run
   nothing to do
-  $ cat .hg/requires
+  $ hg debugrequires
   dotencode
   fncache
   generaldelta
@@ -1322,7 +1322,7 @@ 
   $ touch foo
   $ hg add foo
   $ hg -q commit -m "foo"
-  $ cat .hg/requires
+  $ hg debugrequires
   dotencode
   fncache
   generaldelta
@@ -1344,7 +1344,7 @@ 
     - changelog
     - manifest
   
-  $ cat .hg/requires
+  $ hg debugrequires
   dotencode
   fncache
   generaldelta
@@ -1367,7 +1367,7 @@ 
     - changelog
     - manifest
   
-  $ cat .hg/requires
+  $ hg debugrequires
   dotencode
   fncache
   generaldelta
@@ -1412,7 +1412,7 @@ 
   compression:        zlib   zlib    zlib (no-zstd !)
   compression:        zstd   zlib    zstd (zstd !)
   compression-level:  default default default
-  $ cat .hg/requires
+  $ hg debugrequires
   dotencode
   fncache
   generaldelta
@@ -1454,7 +1454,7 @@ 
   compression:        zlib   zlib    zlib (no-zstd !)
   compression:        zlib   zlib    zstd (zstd !)
   compression-level:  default default default
-  $ cat .hg/requires
+  $ hg debugrequires
   dotencode
   fncache
   generaldelta
@@ -1499,7 +1499,7 @@ 
   compression:        zlib   zlib    zlib (no-zstd !)
   compression:        zstd   zstd    zstd (zstd !)
   compression-level:  default default default
-  $ cat .hg/requires
+  $ hg debugrequires
   dotencode
   fncache
   generaldelta
@@ -1550,7 +1550,7 @@ 
   compression:        zlib   zlib    zlib (no-zstd !)
   compression:        zstd   zstd    zstd (zstd !)
   compression-level:  default default default
-  $ cat .hg/requires
+  $ hg debugrequires
   dotencode
   exp-revlogv2.2
   fncache
@@ -1598,7 +1598,7 @@ 
   compression:        zlib   zlib    zlib (no-zstd !)
   compression:        zstd   zstd    zstd (zstd !)
   compression-level:  default default default
-  $ cat .hg/requires
+  $ hg debugrequires
   dotencode
   fncache
   generaldelta
@@ -1647,7 +1647,7 @@ 
   compression:        zlib   zlib    zlib (no-zstd !)
   compression:        zstd   zstd    zstd (zstd !)
   compression-level:  default default default
-  $ cat .hg/requires
+  $ hg debugrequires
   dotencode
   exp-revlogv2.2
   fncache