Patchwork D11214: help: indicate how to run downgrade a repository using persistent nodemap

login
register
mail settings
Submitter phabricator
Date July 26, 2021, 9:52 p.m.
Message ID <differential-rev-PHID-DREV-wcj72gnwpjfsbkgb3cq6-req@mercurial-scm.org>
Download mbox | patch
Permalink /patch/49528/
State Superseded
Headers show

Comments

phabricator - July 26, 2021, 9:52 p.m.
marmoute created this revision.
Herald added a reviewer: hg-reviewers.
Herald added a subscriber: mercurial-patches.

REVISION SUMMARY
  We have a couple of report of people needing this. I am not fan of pointing
  people to a debug command, but we don't have much better to offer right now

REPOSITORY
  rHG Mercurial

BRANCH
  stable

REVISION DETAIL
  https://phab.mercurial-scm.org/D11214

AFFECTED FILES
  mercurial/helptext/config.txt

CHANGE DETAILS




To: marmoute, #hg-reviewers
Cc: mercurial-patches, mercurial-devel

Patch

diff --git a/mercurial/helptext/config.txt b/mercurial/helptext/config.txt
--- a/mercurial/helptext/config.txt
+++ b/mercurial/helptext/config.txt
@@ -913,6 +913,14 @@ 
     By default this format variant is disabled if fast implementation is not
     available and enabled by default if the fast implementation is available.
 
+    To accomodate install of Mercurial without the fast implementation you can
+    downgrade your repository. To do so run the following command:
+
+    $ hg debugupgraderepo \
+          --run \
+          --config format.use-persistent-nodemap=False \
+          --config storage.revlog.persistent-nodemap.slow-path=allow
+
 ``use-share-safe``
     Enforce "safe" behaviors for all "shares" that access this repository.