Patchwork D9484: upgrade: drop an outdated comment

login
register
mail settings
Submitter phabricator
Date Dec. 1, 2020, 10:12 p.m.
Message ID <differential-rev-PHID-DREV-gycrhxlf47xx6g3g653h-req@mercurial-scm.org>
Download mbox | patch
Permalink /patch/47766/
State Superseded
Headers show

Comments

phabricator - Dec. 1, 2020, 10:12 p.m.
marmoute created this revision.
Herald added a reviewer: hg-reviewers.
Herald added a subscriber: mercurial-patches.

REVISION SUMMARY
  We can control the added/removed requirement through config for multiple years.

REPOSITORY
  rHG Mercurial

BRANCH
  default

REVISION DETAIL
  https://phab.mercurial-scm.org/D9484

AFFECTED FILES
  mercurial/upgrade.py

CHANGE DETAILS




To: marmoute, #hg-reviewers
Cc: mercurial-patches, mercurial-devel

Patch

diff --git a/mercurial/upgrade.py b/mercurial/upgrade.py
--- a/mercurial/upgrade.py
+++ b/mercurial/upgrade.py
@@ -74,8 +74,6 @@ 
     # Ensure the repository can be upgraded.
     upgrade_actions.check_source_requirements(repo)
 
-    # FUTURE there is potentially a need to control the wanted requirements via
-    # command arguments or via an extension hook point.
     newreqs = localrepo.newreporequirements(
         repo.ui, localrepo.defaultcreateopts(repo.ui)
     )