Patchwork [1,of,2,v3] relnotes: note that we now require modern SSL/TLS features in Python

login
register
mail settings
Submitter Manuel Jacob
Date May 31, 2020, 3:58 a.m.
Message ID <d5441892eb22aa451bb4.1590897530@tmp>
Download mbox | patch
Permalink /patch/46430/
State Accepted
Headers show

Comments

Manuel Jacob - May 31, 2020, 3:58 a.m.
# HG changeset patch
# User Manuel Jacob <me@manueljacob.de>
# Date 1590873537 -7200
#      Sat May 30 23:18:57 2020 +0200
# Node ID d5441892eb22aa451bb479919e95f671e99857eb
# Parent  ed05581cec9e829ee4dd3daef8fc4fdd63f6ab54
# EXP-Topic require_modern_ssl
relnotes: note that we now require modern SSL/TLS features in Python
Yuya Nishihara - May 31, 2020, 6:06 a.m.
On Sun, 31 May 2020 05:58:50 +0200, Manuel Jacob wrote:
> # HG changeset patch
> # User Manuel Jacob <me@manueljacob.de>
> # Date 1590873537 -7200
> #      Sat May 30 23:18:57 2020 +0200
> # Node ID d5441892eb22aa451bb479919e95f671e99857eb
> # Parent  ed05581cec9e829ee4dd3daef8fc4fdd63f6ab54
> # EXP-Topic require_modern_ssl
> relnotes: note that we now require modern SSL/TLS features in Python

Queued this for default, thanks.

Patch

diff --git a/relnotes/next b/relnotes/next
--- a/relnotes/next
+++ b/relnotes/next
@@ -6,6 +6,9 @@ 
 
 == Backwards Compatibility Changes ==
 
+* Mercurial now requires at least Python 2.7.9 or a Python version that
+  backported modern SSL/TLS features (as defined in PEP 466).
+
 
 == Internal API Changes ==