Patchwork D7220: contrib: require Python 3.7 for byteify-strings.py

login
register
mail settings
Submitter phabricator
Date Nov. 4, 2019, 10:08 p.m.
Message ID <ceafe9e7e56c50529989a3ad71425578@localhost.localdomain>
Download mbox | patch
Permalink /patch/42734/
State Not Applicable
Headers show

Comments

phabricator - Nov. 4, 2019, 10:08 p.m.
Closed by commit rHG09234eeae206: contrib: require Python 3.7 for byteify-strings.py (authored by Kwan).
This revision was automatically updated to reflect the committed changes.
This revision was not accepted when it landed; it landed in state "Needs Review".

REPOSITORY
  rHG Mercurial

CHANGES SINCE LAST UPDATE
  https://phab.mercurial-scm.org/D7220?vs=17535&id=17540

CHANGES SINCE LAST ACTION
  https://phab.mercurial-scm.org/D7220/new/

REVISION DETAIL
  https://phab.mercurial-scm.org/D7220

AFFECTED FILES
  contrib/byteify-strings.py
  tests/test-byteify-strings.t

CHANGE DETAILS




To: Kwan, #hg-reviewers
Cc: mjpieters, mercurial-devel

Patch

diff --git a/tests/test-byteify-strings.t b/tests/test-byteify-strings.t
--- a/tests/test-byteify-strings.t
+++ b/tests/test-byteify-strings.t
@@ -1,4 +1,4 @@ 
-#require py36
+#require py37
 
   $ byteify_strings () {
   >   $PYTHON "$TESTDIR/../contrib/byteify-strings.py" "$@"
diff --git a/contrib/byteify-strings.py b/contrib/byteify-strings.py
--- a/contrib/byteify-strings.py
+++ b/contrib/byteify-strings.py
@@ -339,7 +339,7 @@ 
 
 
 if __name__ == '__main__':
-    if sys.version_info[0:2] < (3, 6):
-        print('This script must be run under Python 3.6+')
+    if sys.version_info[0:2] < (3, 7):
+        print('This script must be run under Python 3.7+')
         sys.exit(3)
     main()