Patchwork D6758: narrow: fix typo "respositories"

login
register
mail settings
Submitter phabricator
Date Aug. 22, 2019, 11:51 p.m.
Message ID <differential-rev-PHID-DREV-ph4qkxarmw2eh6f5t46u-req@mercurial-scm.org>
Download mbox | patch
Permalink /patch/41388/
State Superseded
Headers show

Comments

phabricator - Aug. 22, 2019, 11:51 p.m.
martinvonz created this revision.
Herald added a reviewer: durin42.
Herald added a subscriber: mercurial-devel.
Herald added a reviewer: hg-reviewers.

REPOSITORY
  rHG Mercurial

REVISION DETAIL
  https://phab.mercurial-scm.org/D6758

AFFECTED FILES
  hgext/narrow/narrowcommands.py
  tests/test-narrow-trackedcmd.t

CHANGE DETAILS




To: martinvonz, durin42, #hg-reviewers
Cc: mercurial-devel

Patch

diff --git a/tests/test-narrow-trackedcmd.t b/tests/test-narrow-trackedcmd.t
--- a/tests/test-narrow-trackedcmd.t
+++ b/tests/test-narrow-trackedcmd.t
@@ -220,5 +220,5 @@ 
   $ hg init non-narrow
   $ cd non-narrow
   $ hg tracked --addinclude foobar
-  abort: the tracked command is only supported on respositories cloned with --narrow
+  abort: the tracked command is only supported on repositories cloned with --narrow
   [255]
diff --git a/hgext/narrow/narrowcommands.py b/hgext/narrow/narrowcommands.py
--- a/hgext/narrow/narrowcommands.py
+++ b/hgext/narrow/narrowcommands.py
@@ -368,7 +368,7 @@ 
     opts = pycompat.byteskwargs(opts)
     if repository.NARROW_REQUIREMENT not in repo.requirements:
         raise error.Abort(_('the tracked command is only supported on '
-                            'respositories cloned with --narrow'))
+                            'repositories cloned with --narrow'))
 
     # Before supporting, decide whether it "hg tracked --clear" should mean
     # tracking no paths or all paths.