Patchwork D6399: tests: fix test-clonebundles on recent openbsd

login
register
mail settings
Submitter phabricator
Date May 18, 2019, 2:31 p.m.
Message ID <4cac36fbe3accfebcf7860555ec9b3f0@localhost.localdomain>
Download mbox | patch
Permalink /patch/40136/
State Not Applicable
Headers show

Comments

phabricator - May 18, 2019, 2:31 p.m.
This revision was automatically updated to reflect the committed changes.
Closed by commit rHGda3861ef7959: tests: fix test-clonebundles on recent openbsd (authored by durin42, committed by ).

REPOSITORY
  rHG Mercurial

CHANGES SINCE LAST UPDATE
  https://phab.mercurial-scm.org/D6399?vs=15171&id=15187

REVISION DETAIL
  https://phab.mercurial-scm.org/D6399

AFFECTED FILES
  tests/test-clonebundles.t

CHANGE DETAILS




To: durin42, #hg-reviewers, pulkit
Cc: mercurial-devel

Patch

diff --git a/tests/test-clonebundles.t b/tests/test-clonebundles.t
--- a/tests/test-clonebundles.t
+++ b/tests/test-clonebundles.t
@@ -53,7 +53,7 @@ 
   $ echo 'http://does.not.exist/bundle.hg' > server/.hg/clonebundles.manifest
   $ hg clone http://localhost:$HGPORT 404-url
   applying clone bundle from http://does.not.exist/bundle.hg
-  error fetching bundle: (.* not known|(\[Errno -?\d+])? No address associated with hostname) (re) (no-windows !)
+  error fetching bundle: (.* not known|(\[Errno -?\d+])? [Nn]o address associated with (host)?name) (re) (no-windows !)
   error fetching bundle: [Errno 1100*] getaddrinfo failed (glob) (windows !)
   abort: error applying bundle
   (if this error persists, consider contacting the server operator or disable clone bundles via "--config ui.clonebundles=false")