Patchwork [evolve-ext] legacy: drop the check for `obsolete._enabled`

login
register
mail settings
Submitter Matt Harbison
Date April 30, 2019, 3:18 a.m.
Message ID <6ee8b75ac34337d13309.1556594303@Envy>
Download mbox | patch
Permalink /patch/39904/
State New
Headers show

Comments

Matt Harbison - April 30, 2019, 3:18 a.m.
# HG changeset patch
# User Matt Harbison <matt_harbison@yahoo.com>
# Date 1556594189 14400
#      Mon Apr 29 23:16:29 2019 -0400
# Node ID 6ee8b75ac34337d13309044cd1fd6cbf13de0ff1
# Parent  5c913f7081b36f71c3678f3686f89d5365e7bdeb
legacy: drop the check for `obsolete._enabled`

This looks like an ancient version check, and presumably `minimumhgversion` will
do the same thing.

Patch

diff --git a/hgext3rd/evolve/legacy.py b/hgext3rd/evolve/legacy.py
--- a/hgext3rd/evolve/legacy.py
+++ b/hgext3rd/evolve/legacy.py
@@ -15,12 +15,6 @@ 
 
 from mercurial import error
 
-try:
-    from mercurial import obsolete
-    obsolete._enabled
-except ImportError:
-    raise error.Abort('Obsolete extension requires Mercurial 2.3 (or later)')
-
 import sys
 import json