Patchwork D2386: narrowbundle2: drop legacy getcgkwargs variable

login
register
mail settings
Submitter phabricator
Date Feb. 22, 2018, 6:29 a.m.
Message ID <b4b19ddc0c7f37c945fa2079cab9764d@localhost.localdomain>
Download mbox | patch
Permalink /patch/28243/
State Not Applicable
Headers show

Comments

phabricator - Feb. 22, 2018, 6:29 a.m.
This revision was automatically updated to reflect the committed changes.
Closed by commit rHGeee738c5a899: narrowbundle2: drop legacy getcgkwargs variable (authored by durin42, committed by ).

REPOSITORY
  rHG Mercurial

CHANGES SINCE LAST UPDATE
  https://phab.mercurial-scm.org/D2386?vs=5985&id=5990

REVISION DETAIL
  https://phab.mercurial-scm.org/D2386

AFFECTED FILES
  hgext/narrow/narrowbundle2.py

CHANGE DETAILS




To: durin42, #hg-reviewers, indygreg
Cc: mercurial-devel

Patch

diff --git a/hgext/narrow/narrowbundle2.py b/hgext/narrow/narrowbundle2.py
--- a/hgext/narrow/narrowbundle2.py
+++ b/hgext/narrow/narrowbundle2.py
@@ -219,13 +219,12 @@ 
                                     bundlecaps=None, b2caps=None, heads=None,
                                     common=None, **kwargs):
     cgversions = b2caps.get('changegroup')
-    getcgkwargs = {}
     if cgversions:  # 3.1 and 3.2 ship with an empty value
         cgversions = [v for v in cgversions
                       if v in changegroup.supportedoutgoingversions(repo)]
         if not cgversions:
             raise ValueError(_('no common changegroup version'))
-        version = getcgkwargs['version'] = max(cgversions)
+        version = max(cgversions)
     else:
         raise ValueError(_("server does not advertise changegroup version,"
                            " can't negotiate support for ellipsis nodes"))