Patchwork D2202: tests: remove code to support Mercurial 4.3

login
register
mail settings
Submitter phabricator
Date Feb. 13, 2018, 12:31 a.m.
Message ID <differential-rev-PHID-DREV-vjyxmxb7q25axphr3uf3-req@phab.mercurial-scm.org>
Download mbox | patch
Permalink /patch/27750/
State Superseded
Headers show

Comments

phabricator - Feb. 13, 2018, 12:31 a.m.
indygreg created this revision.
Herald added a subscriber: mercurial-devel.
Herald added a reviewer: hg-reviewers.

REVISION SUMMARY
  Now that narrow lives in core, we don't need the legacy support.

REPOSITORY
  rHG Mercurial

REVISION DETAIL
  https://phab.mercurial-scm.org/D2202

AFFECTED FILES
  tests/test-narrow-expanddirstate.t

CHANGE DETAILS




To: indygreg, #hg-reviewers
Cc: mercurial-devel

Patch

diff --git a/tests/test-narrow-expanddirstate.t b/tests/test-narrow-expanddirstate.t
--- a/tests/test-narrow-expanddirstate.t
+++ b/tests/test-narrow-expanddirstate.t
@@ -75,23 +75,13 @@ 
   >   def wrapds(orig, self):
   >     ds = orig(self)
   >     class expandingdirstate(ds.__class__):
-  >       # Mercurial 4.4 uses this version.
   >       @hgutil.propertycache
   >       def _map(self):
   >         ret = super(expandingdirstate, self)._map
   >         with repo.wlock(), repo.lock(), repo.transaction(
   >             'expandnarrowspec'):
   >           expandnarrowspec(ui, repo, os.environ.get('DIRSTATEINCLUDES'))
   >         return ret
-  >       # Mercurial 4.3.3 and earlier uses this version. It seems that
-  >       # narrowhg does not currently support this version, but we include
-  >       # it just in case backwards compatibility is restored.
-  >       def _read(self):
-  >         ret = super(expandingdirstate, self)._read()
-  >         with repo.wlock(), repo.lock(), repo.transaction(
-  >             'expandnarrowspec'):
-  >           expandnarrowspec(ui, repo, os.environ.get('DIRSTATEINCLUDES'))
-  >         return ret
   >     ds.__class__ = expandingdirstate
   >     return ds
   >   return wrapds