Patchwork D1958: tests: allow [Errno] in output

login
register
mail settings
Submitter phabricator
Date Jan. 31, 2018, 7:04 p.m.
Message ID <differential-rev-PHID-DREV-6fkgc4j4xmpnrgdrx3m4-req@phab.mercurial-scm.org>
Download mbox | patch
Permalink /patch/27098/
State Superseded
Headers show

Comments

phabricator - Jan. 31, 2018, 7:04 p.m.
indygreg created this revision.
Herald added a subscriber: mercurial-devel.
Herald added a reviewer: hg-reviewers.

REVISION SUMMARY
  I'm not sure why, but my system is printing "[Errno -5]" before
  the "No address associated with hostname" message. I suspect a
  modern version of Python improved errno tracking or something.
  
  Add an "[Errno ...]" pattern as optional output to make the test
  pass.

REPOSITORY
  rHG Mercurial

REVISION DETAIL
  https://phab.mercurial-scm.org/D1958

AFFECTED FILES
  tests/test-clonebundles.t

CHANGE DETAILS




To: indygreg, #hg-reviewers
Cc: mercurial-devel

Patch

diff --git a/tests/test-clonebundles.t b/tests/test-clonebundles.t
--- a/tests/test-clonebundles.t
+++ b/tests/test-clonebundles.t
@@ -53,7 +53,7 @@ 
   $ echo 'http://does.not.exist/bundle.hg' > server/.hg/clonebundles.manifest
   $ hg clone http://localhost:$HGPORT 404-url
   applying clone bundle from http://does.not.exist/bundle.hg
-  error fetching bundle: (.* not known|No address associated with hostname) (re) (no-windows !)
+  error fetching bundle: (.* not known|(\[Errno -?\d+])? No address associated with hostname) (re) (no-windows !)
   error fetching bundle: [Errno 11004] getaddrinfo failed (windows !)
   abort: error applying bundle
   (if this error persists, consider contacting the server operator or disable clone bundles via "--config ui.clonebundles=false")