Patchwork [1,of,3,evolve-ext] warning: use 'divergent', not 'contentdivergent' on old Mercurial

login
register
mail settings
Submitter via Mercurial-devel
Date Aug. 24, 2017, 6:02 p.m.
Message ID <f56cdb3e73fddd085e84.1503597767@martinvonz.svl.corp.google.com>
Download mbox | patch
Permalink /patch/23306/
State Accepted
Headers show

Comments

via Mercurial-devel - Aug. 24, 2017, 6:02 p.m.
# HG changeset patch
# User Martin von Zweigbergk <martinvonz@google.com>
# Date 1503596918 25200
#      Thu Aug 24 10:48:38 2017 -0700
# Node ID f56cdb3e73fddd085e84a3ba58367a83ad1f71ee
# Parent  f6517779a7c47471772dbbfb7025050ed71650ab
warning: use 'divergent', not 'contentdivergent' on old Mercurial

This was just an oversight in f6517779a7c4 (warning: rename warning
message, 2017-08-24).

Patch

diff --git a/hgext3rd/evolve/__init__.py b/hgext3rd/evolve/__init__.py
--- a/hgext3rd/evolve/__init__.py
+++ b/hgext3rd/evolve/__init__.py
@@ -777,7 +777,7 @@ 
     if newbumpeds > 0:
         ui.warn(base_msg % (newbumpeds, compat.TROUBLES['PHASEDIVERGENT']))
     if newdivergents > 0:
-        ui.warn(_('%i new contentdivergent changesets\n') % newdivergents)
+        ui.warn(base_msg % (newdivergents, compat.TROUBLES['CONTENTDIVERGENT']))
     return ret
 
 @eh.wrapfunction(mercurial.exchange, 'push')