Patchwork [1,of,3] rpms: remove '%if "%{?pythonver}" != "2.4"'

login
register
mail settings
Submitter Toshi MARUYAMA
Date June 11, 2017, 7:11 p.m.
Message ID <7874ec2cd27c5cba5002.1497208288@raidcentos7n01>
Download mbox | patch
Permalink /patch/21331/
State Accepted
Headers show

Comments

Toshi MARUYAMA - June 11, 2017, 7:11 p.m.
# HG changeset patch
# User Toshi MARUYAMA <marutosijp2@gmail.com>
# Date 1497205365 -32400
#      Mon Jun 12 03:22:45 2017 +0900
# Node ID 7874ec2cd27c5cba500299f8ae5b71af85dfda73
# Parent  cba4461aa0a0f238401b8062867dff7b5a6ecf45
rpms: remove '%if "%{?pythonver}" != "2.4"'

Mercurial requires python >= 2.7.

Patch

diff --git a/contrib/mercurial.spec b/contrib/mercurial.spec
--- a/contrib/mercurial.spec
+++ b/contrib/mercurial.spec
@@ -153,9 +153,7 @@  rm -rf $RPM_BUILD_ROOT
 %{_bindir}/%{pythonhg}
 %{hgpyprefix}
 %else
-%if "%{?pythonver}" != "2.4"
 %{_libdir}/python%{pythonver}/site-packages/%{name}-*-py%{pythonver}.egg-info
-%endif
 %{_libdir}/python%{pythonver}/site-packages/%{name}
 %{_libdir}/python%{pythonver}/site-packages/hgext
 %{_libdir}/python%{pythonver}/site-packages/hgext3rd