Patchwork [remotenames-ext] wrappers: update dynamicblocker wrapper

login
register
mail settings
Submitter Durham Goode
Date May 24, 2017, 4:12 p.m.
Message ID <d7e724c0409b11e786ee24be0593f280-b13a8f0@22e1355dafec464bc31cce9356b25ea4f77677f4a071c344f64fcc94f6c51c4f>
Download mbox | patch
Permalink /patch/20884/
State Accepted
Headers show

Comments

Durham Goode - May 24, 2017, 4:12 p.m.
# HG changeset patch
# User Durham Goode <durham@fb.com>
# Date 1495642272 25200
#      Wed May 24 09:11:12 2017 -0700
# Node ID 900f1c70436bd7a266f64a6db592af602f8138a5
# Parent  7be28b9ec6ffc0ec02be7ad4c28b3d442998e527
wrappers: update dynamicblocker wrapper

Upstream renamed _getdynamicblocks to revealedrevs. We need to update to that.
This will make remotenames incompatible with older versions of hg. I don't know
what the BC model is on remotenames though.

Patch

diff --git a/remotenames.py b/remotenames.py
--- a/remotenames.py
+++ b/remotenames.py
@@ -646,7 +646,7 @@  def extsetup(ui):
     extensions.wrapfunction(exchange.pushoperation, '__init__', expushop)
     extensions.wrapfunction(exchange, 'push', expush)
     extensions.wrapfunction(exchange, 'pull', expull)
-    extensions.wrapfunction(repoview, '_getdynamicblockers', blockerhook)
+    extensions.wrapfunction(repoview, 'revealedrevs', blockerhook)
     extensions.wrapfunction(bookmarks, 'updatefromremote', exupdatefromremote)
     extensions.wrapfunction(repair, 'stripbmrevset', exstripbmrevset)
     if util.safehasattr(bookmarks, 'activate'):