Patchwork [2,of,2] hghave: remove py27+ capability

login
register
mail settings
Submitter Gregory Szorc
Date May 8, 2017, 10:32 p.m.
Message ID <48936726f8731b840cb7.1494282752@ubuntu-vm-main>
Download mbox | patch
Permalink /patch/20527/
State Accepted
Headers show

Comments

Gregory Szorc - May 8, 2017, 10:32 p.m.
# HG changeset patch
# User Gregory Szorc <gregory.szorc@gmail.com>
# Date 1494282694 25200
#      Mon May 08 15:31:34 2017 -0700
# Node ID 48936726f8731b840cb7bd08fcf5ec5af0b4cc7a
# Parent  50eabab39ddfb8b5db7acef36827755166a59a9d
hghave: remove py27+ capability

It is now unused. And we require Python 2.7+ now so this check is not
necessary.

Patch

diff --git a/tests/hghave.py b/tests/hghave.py
--- a/tests/hghave.py
+++ b/tests/hghave.py
@@ -580,10 +580,6 @@  def has_absimport():
     from mercurial import util
     return util.safehasattr(__future__, "absolute_import")
 
-@check("py27+", "running with Python 2.7+")
-def has_python27ornewer():
-    return sys.version_info[0:2] >= (2, 7)
-
 @check("py3k", "running with Python 3.x")
 def has_py3k():
     return 3 == sys.version_info[0]