Patchwork [3,of,3] evolve: drop point release of versions

login
register
mail settings
Submitter Pulkit Goyal
Date Sept. 1, 2016, 2:13 a.m.
Message ID <3f1d6170cb2a3a967d0e.1472695981@pulkit-goyal>
Download mbox | patch
Permalink /patch/16524/
State Accepted
Headers show

Comments

Pulkit Goyal - Sept. 1, 2016, 2:13 a.m.
# HG changeset patch
# User Pulkit Goyal <7895pulkit@gmail.com>
# Date 1472695827 -19800
#      Thu Sep 01 07:40:27 2016 +0530
# Branch stable
# Node ID 3f1d6170cb2a3a967d0eaa08c8d3a80037948bf0
# Parent  2ab652cca0c72df663446cc5e79bef2afa0e9854
evolve: drop point release of versions

Modern Mercurial only looks at X.Y versions, so point releases can be dropped.
Pierre-Yves David - Sept. 6, 2016, 12:31 p.m.
On 09/01/2016 04:13 AM, Pulkit Goyal wrote:
> # HG changeset patch
> # User Pulkit Goyal <7895pulkit@gmail.com>
> # Date 1472695827 -19800
> #      Thu Sep 01 07:40:27 2016 +0530
> # Branch stable
> # Node ID 3f1d6170cb2a3a967d0eaa08c8d3a80037948bf0
> # Parent  2ab652cca0c72df663446cc5e79bef2afa0e9854
> evolve: drop point release of versions
>
> Modern Mercurial only looks at X.Y versions, so point releases can be dropped.

And that one is taken too, thanks. I had to adapt it a bit because you 
apparently built it against an old version of evolve.

Patch

diff -r 2ab652cca0c7 -r 3f1d6170cb2a hgext/evolve.py
--- a/hgext/evolve.py	Thu Sep 01 04:38:56 2016 +0530
+++ b/hgext/evolve.py	Thu Sep 01 07:40:27 2016 +0530
@@ -20,7 +20,7 @@ 
 '''
 
 __version__ = '5.4.0'
-testedwith = '3.4.3 3.5.2 3.6.2 3.7.3 3.8.1'
+testedwith = '3.4 3.5 3.6 3.7 3.8'
 buglink = 'https://bz.mercurial-scm.org/'
 
 
diff -r 2ab652cca0c7 -r 3f1d6170cb2a hgext/simple4server.py
--- a/hgext/simple4server.py	Thu Sep 01 04:38:56 2016 +0530
+++ b/hgext/simple4server.py	Thu Sep 01 07:40:27 2016 +0530
@@ -8,7 +8,7 @@ 
 For client side usages it is recommended to use the evolve extension for
 improved user interface.'''
 
-testedwith = '3.3.3 3.4-rc'
+testedwith = '3.3 3.4-rc'
 buglink = 'https://bz.mercurial-scm.org/'
 
 import mercurial.obsolete