Patchwork [Bug,5181] New: buildbot have an outdate version of git

login
register
mail settings
Submitter mercurial-bugs@selenic.com
Date April 5, 2016, 1:09 a.m.
Message ID <bug-5181-285@https.bz.mercurial-scm.org/>
Download mbox | patch
Permalink /patch/14359/
State Not Applicable
Headers show

Comments

mercurial-bugs@selenic.com - April 5, 2016, 1:09 a.m.
https://bz.mercurial-scm.org/show_bug.cgi?id=5181

            Bug ID: 5181
           Summary: buildbot have an outdate version of git
           Product: Mercurial
           Version: unspecified
          Hardware: PC
                OS: Linux
            Status: UNCONFIRMED
          Severity: feature
          Priority: wish
         Component: infrastructure
          Assignee: bugzilla@selenic.com
          Reporter: pierre-yves.david@ens-lyon.org
                CC: kbullock+mercurial@ringworld.org,
                    mercurial-devel@selenic.com

The tests are failing because the git version is vulnerable:

   abort: git clone error 128 in s (in subrepo s)

ERROR: test-subrepo-git.t output changed
!............s.............................


http://buildbot.mercurial-scm.org/builders/hg%20tests/builds/165/steps/run-tests.py%20%28python%202.6.9%29/logs/stdio

Patch

--- /srv/buildbot/linuxtests/hg_coverage/build/tests/test-subrepo-git.t
+++ /srv/buildbot/linuxtests/hg_coverage/build/tests/test-subrepo-git.t.err
@@ -1147,7 +1147,11 @@ 
   $ cd ..
   $ env -u GIT_ALLOW_PROTOCOL hg clone malicious-subrepository
malicious-subrepository-protected
   Cloning into '$TESTTMP/tc/malicious-subrepository-protected/s'...
-  fatal: transport 'ext' not allowed
+  pwned
+  fatal: Could not read from remote repository.
+  
+  Please make sure you have the correct access rights
+  and the repository exists.
   updating to branch default
   cloning subrepo s from ext::sh -c echo% pwned% >&2